Adjusting the window settings and layout

Last updated: July 14, 2022

Creating windows MA!N takes more than coding. Making a usable user interface also requires adjusting the styling, layout and grid settings. This section covers the layout and grid settings.

Change the window layout

You can change the layout of elements in the window container by dragging the individual windows.

  • Enable dragging by deselecting Docking. In the menu bar, go to File, make sure that Docking is not checked.
  • With your mouse, left click and hold the title bar of the window that you want to move.
  • You can now drag and drop the window manually or use the auto handler that appears.

Save the window layout

You save your changes by going to menu bar “File > Layout Save Group”. By selecting Layout Save File, you save the layout to a file that you can use or share.

Adjusting an individual data grid settings

Right-click the data grid that you want to adjust and choose “Layout > Adjust layout”. A separate window opens where you can set the appearance of the data grid.

Screenshot of the adjust layout and grid settings in MAIN

Example: make a filter button visible or invisible in a data grid:

  • DisplayLayout > Bands > 0 > OverrideAllowRowFiltering, set value to “False”;

Example: show a group by box:

  • DisplayLayout > GroupByBox > Hidden, set value to “True”.

Example: change the view of a grid:

  • By default, a datagrid is displayed with horizontal columns. By choosing the “card-view” option value “true” MA!N displays the columns vertical.
  • To do this, go to “Displaylayout > bands > 0 – data > card-view”.

Save data grid changes

After the adjustments, you close the window. Now you only need to save the changes. Right-click on the adjusted grid and choose “Layout > Save Group Control”.